Справочный центр

Just Hosting > Справочный центр > Программное обеспечение

Для того, чтобы PHP код выполнялся на статических html страницах, необходимо в .htaccess прописать:
RemoveHandler .html
AddType application/x-httpd-php .html
Также, через пробел, можно добавить другие расширения.
В данном случае, PHP начинает работать как модуль apache, просьба учитывать это, и предварительно проверить права на файлы и директории.

В случае, если PHP работает как CGI, используется другая директива:
AddHandler php-cgi .html
Читать полностью...
Тип услуги: Виртуальный хостинг
Поскольку для всех пользователей предоставляется полный доступ к php.ini, вы можете самостоятельно отключить эту директиву, для этого пропишите в /php-bin/php.ini:

magic_quotes_gpc = Off


Если требуется, предварительно выставьте на файл права доступа позволяющие запись (например, "644"), после редактирования рекомендуется вернуть прежние права. Читать полностью...
Тип услуги: Виртуальный хостинг
После переноса сайта требуется изменить параметры для подключения к БД, ниже приведена информация о месте и формате хранения этих данных некоторыми популярными CMS.

db_name — имя базы данных.
db_user — имя пользователя БД.
db_password — пароль пользователя БД. Читать полностью...
Тип услуги: Виртуальный хостинг
Для того, чтобы включить директиву, пропишите в /php-bin/php.ini
register_globals = On

Отключить:
register_globals = Off


Если требуется, предварительно выставьте на файл права доступа позволяющие запись (например, "644"), после редактирования рекомендуется вернуть прежние права. Читать полностью...
Для подключения расширения Zend Guard Loader (требуется для запуска закодированных с помощью Zend Guard скриптов), достаточно добавить директиву для загрузки соответствующего расширения в файл конфигурации /php-bin/php.ini.

Если требуется, предварительно выставьте на файл права доступа позволяющие запись (например, "644"), после редактирования рекомендуется вернуть прежние права.

Обратите внимание, что для следующих версий PHP расширение включено по умолчанию: 5.2.6, 5.3.3, 5.3.3-i386.
Для всех остальных версий, достаточно добавить в php.ini следующие директивы:

Для PHP 5.3.28
zend_extension = /opt/loaders/zend/zend_loader_lin_5.3.so

Для PHP 5.4.30
zend_extension = /opt/loaders/zend/zend_loader_lin_5.4.so


Для версий 5.5.14 и 5.6.0-rc1 расширения Zend Guard Loader на данный момент не существует. Читать полностью...
Для подключения расширения Ioncube Loader (требуется для запуска закодированных с помощью Ioncube Encoder скриптов), необходимо добавить директиву для загрузки соответствующего расширения в файл конфигурации /php-bin/php.ini.

Если требуется, предварительно выставьте на файл права доступа позволяющие запись (например, "644"), после редактирования рекомендуется вернуть прежние права.

Для PHP 4.4
zend_extension = /opt/loaders/ioncube/ioncube_loader_lin_4.4.so


Для PHP 5.0
zend_extension = /opt/loaders/ioncube/ioncube_loader_lin_5.0.so


Для PHP 5.1
zend_extension = /opt/loaders/ioncube/ioncube_loader_lin_5.1.so


Для PHP 5.2
zend_extension = /opt/loaders/ioncube/ioncube_loader_lin_5.2.so


Для PHP 5.3
zend_extension = /opt/loaders/ioncube/ioncube_loader_lin_5.3.so


Для PHP 5.4
zend_extension = /opt/loaders/ioncube/ioncube_loader_lin_5.4.so


Для PHP 5.5
zend_extension = /opt/loaders/ioncube/ioncube_loader_lin_5.5.so
Читать полностью...
Тип услуги: Виртуальный хостинг
Выбор версии интерпретатора PHP осуществляется в меню Настройки PHP в панели управления ISPManager.

Обратите внимание, что использование старых (не поддерживаемых), а также находящихся в разработке версий рекомендуется лишь в том случае, если у вас имеются скрипты, запуск которых по тем или иным причинами не возможен с помощью актуальных стабильных версий интерпретатора.


Доступные на данный момент версии интерпретатора:

4.4.9 (устаревшая стабильная, не поддерживаемая)
5.0.5 (устаревшая стабильная, не поддерживаемая)
5.1.6 (устаревшая стабильная, не поддерживаемая)
5.2.6-1+lenny16 (устаревшая стабильная, не поддерживаемая)
5.3.3-7+squeeze19 (старая стабильная, поддерживаемая)
5.3.3-7+squeeze19-i386 (старая стабильная, поддерживаемая, 32-х битная)
5.3.28 (старая стабильная, поддерживаемая)
5.4.30 (текущая стабильная, поддерживаемая)
5.5.14 (текущая стабильная, поддерживаемая)
5.6.1 (текущая стабильная, поддерживаемая)
7.0.1 (текущая стабильная, поддерживаемая)
Читать полностью...

Если ответ на интересующий вас вопрос не найден...

Тикет система
 
 
Страница сгенерирована за 0.00312 секунд / Количество MySQL запросов: 3 / Использовано оперативной памяти 2.17 MB
Cluster debug: node=4, connection=close, balancer=78.46.222.224,geo=CIS:1;United States